The TLex Suite

2012 / 2013

 

Professional Lexicography, Terminology and Corpus Query Software

 

 

 

 

 

 

 

 

User Guide

 

Version 7.0.4

 

 

 

 

 

 

 

David Joffe

&

Gilles-Maurice de Schryver

 

 

 

 

 

 

 

Copyright © 2004-2013 TshwaneDJe Human Language Technology

http://tshwanedje.com/

 

 

 

Table of Contents

General Notes to the User Guide        1

Terminology Used in this User Guide        1

Frequently Asked Questions (FAQ)        1

ChangeLog        1

Additional Resources        1

Getting Started with TLex: QuickStart Guide        2

Creating a New Dictionary Project        2

Overview of the TLex/tlTerm Interface        3

Monolingual Editing Environment / tlTerm        3

Bilingual Editing Environment        4

Entry List [1] (‘Lemma List’ in TLex, and ‘Term List’ in tlTerm)        4

QuickSearch Box        4

Tree View [2]        5

Attributes (F1, F2) and Tools (F3, F4, F5, F6) Window [3]        5

Preview Area [4]        5

Bilingual “Side-by-Side” View Mode        5

“Expanded View” Mode vs. Side-by-Side View Mode        6

Adding New Entries to the Dictionary/Termbase        6

Structuring Articles with the Tree View Control        6

Changing the Order of Elements        7

Changing the Order of Homonyms        7

Marking Entries as 'Incomplete'        7

Saving Your Work        7

Restoring the Last-saved Version of an Entry ('Undo')        8

Adding a Batch of New Entries, Or ‘Import Wordlist/CSV’        8

Deleting Entries from the Dictionary/Termbase        8

Printing your Dictionary        8

Making Regular Backups        8

Manual Backups        8

Automatic Backups        9

Offsite Backups        9

“Cloud” Backups        9

Getting Started with tlTerm: QuickStart Guide        10

Creating a New Termbase        10

Primary Differences Between tlTerm and TLex        10

Changing the Interface Language (Localisation)        12

Built-in Localisation Editor – Creating New Interface Languages        12

Keeping Your Software Up To Date        14

“Wide View” Mode and “High View” Mode        15

F12 Overlay Window (Larger Attribute Editing Window)        16

Attributes (F1) and (F2)        17

Attributes (F1)        17

“Incomplete” Checkbox        18

Attributes (F2) – Closed Lists with Multiple Selection        18

Editing Attributes        19

Expansion of Tilde Character (~)        19

Overriding the Tilde Substitution Text        19

Using Text Formatting Within a Text Field        20

Markup Characters (Bold, Italics, Underline etc.)        20

Smart Formatting Reversal (%b, %i vs. %B, %I - “soft” vs. “hard” bold/italics)        21

Using Inline Elements for Text Formatting [Advanced]        21

Configurable Keyboard Shortcuts        21

Inline Elements: Special <i>'Tagging'</i> Shortcut Keys [Advanced]        23

Replace As You Type        23

Configuring Replace-As-You-Type [Advanced]        23

Inserting Phonetic Symbols (e.g. IPA)        23

Editing TLex “Smart Cross-references”        25

“Smart” Cross-references: Overview        25

Adding Cross-references        26

Editing Cross-references        27

Customising the Cross-reference Types        27

Search (F3)        28

Overview        28

Search Options        28

“Case Sensitive”        28

“Whole Word Only”        28

“Regular Expression” Searches [Advanced]        28

A Few Useful Regular Expression Example Applications        30

“Find” Tool        30

“Search and Replace” Tool        31

Searching F2 Lists with “Find” and “Search and Replace”        31

Search “Smart Presets”        31

Format (F4)        33

Alternative Sets of Labels for Lists        33

Cross-reference Label Sets        33

Show Related Cross-references [TLex]        34

Expand Entities        34

Show Frequency        34

Expand Tildes (~)        34

Show Timestamp        34

Show Usernames        34

Filter (F5)        35

Types of Filter Conditions        35

“Reveal” Filter        36

“Hide” Filter        37

Combining “Reveal” and “Hide”        37

Extracting or Printing a Subset of the Dictionary/Termbase        38

Corpus (F6)        39

Configuring the Corpus        39

Doing a Corpus Search        39

Sorting the Results        39

Auto-grabbing Usage Examples        39

Copying Selected Examples (Corpus Lines) to the Clipboard        40

Corpus Encryption        40

Corpus Registry Settings [Advanced]        40

Increasing the Maximum Number of Corpus Lines Returned        40

Increasing the Maximum Number of Cached Sets of Search Results        40

Tags        42

Overview        42

Tagging Commands        42

Tag Filter        43

Tagging in the “Find” Tool        43

Tagging a Range of Entries (e.g. an Alphabetic Section)        43

Microsoft Word Integration        44

TLex Bilingual Editing Features        45

Linked View        45

Automatic Lemma Reversal        45

Single Article Reversal        45

Full Dictionary Reversal        45

Translation Equivalent / Term Fanouts [TLex & tlTerm]        46

Compare/Merge        47

Overview        47

Action Commands: “Add”, “Merge”, “Replace” and “Delete Left”        48

Settings        49

Bilingual Dictionaries: Choosing Which Sides to Compare        49

Batch Merge        49

Ruler Tool [Advanced]        51

What is a Multidimensional Lexicographic Ruler?        51

Rulers in TLex        51

Customising the Dictionary Grammar or Termbase Fields using the DTD [Advanced]        54

Basics of Hierarchical Data Modelling        54

Elements and Attributes        54

What is a DTD?        55

Element Types        55

Element Attributes        56

Element Child Relations        57

Element Child Relation Constraints        58

Special Element Types (TLex-internal)        59

Dictionary and Language Elements        59

Lemma Element        59

References Element        59

The TLex Default DTD        59

Elements        59

Attributes        60

Attribute Lists        61

Multimedia (Audio and Images)        65

Special Element and Attribute Types (User-configurable)        65

Translation Equivalent (TE)        65

Frequency        66

Sense        66

Display Lemma Sign        66

Internal ‘Notes’        67

DTD Templates        67

Customising the Cross-reference Types        68

Renaming, Removing and Adding Cross-reference Types        68

Changing the Output Order of Cross-reference Types        68

Creating Singular and Plural Labels for Cross-reference Types        68

Customising the Language used to Display Cross-reference Types        69

Customising the Alphabetic Sorting        71

Overview        71

Table-based Sorting        71

Configuring Table-based Sorting        71

Selecting Other Sort Plug-ins        72

Loading/Saving Sort Configurations        73

Styles System        74

Overview        74

Styles/formatting        74

Basic Formatting Options        74

Font Names Starting With “@”        75

Colours        75

Text Before/After Options        76

Group Style Properties for Multiple Elements or List Items        76

Automatic Numbering        77

Paragraph Style Options (“Indents and Spacing” Tab)        79

Using Paragraph vs “%n” to Generate New-lines Before/Between Elements        79

Paragraphs and “Show whitespace” Option        79

Paragraph Margins (Spacing)        80

Creating a Hanging Indent        80

Creating Nested Indents        80

[Advanced] Notes on Using Paragraph Styles        80

Output (Display) Order        81

Element and Attribute Output (Display) Order        81

“Visible” Flag (Non-Printing Fields)        82

Entities        82

Using Entities to Embed Labels within Other Fields and Further Customisation        83

Style Sets, Or ‘One Database, Many Dictionaries’        85

“Masks” (Selectively Hiding Specific Information on a Per-Edition Basis)        86

Configuring Masks        87

“Smart Styles” (Dynamically Customisable Styles) [Advanced]        89

Creating a Thesaurus        90

Importing Data into TLex/tlTerm        91

Import Wordlist / CSV (Comma Separated Values)        91

Importing XML [Advanced]        93

'Merge' XML Import        94

Post-Import Processing / Data Remodelling        94

“XML Line by Line” Importer        94

Exporting Data from TLex/tlTerm        96

Copying Lemma Signs, Terms and Articles        96

Copy Lemma Sign / Term        96

Copy Entry Text        96

Copy Entry HTML        96

Exporting the Database, in Part or in Full        96

Lemma Signs [TLex] / List of Terms [tlTerm]        96

Text        97

RTF (Rich Text Format)        97

HTML (Web Page)        98

XML (eXtensible Markup Language)        98

XML (Formatted)        99

Exporting to InDesign        99

Exporting to InDesign via RTF        99

Exporting a Range of Entries or a Single Alphabetic Section, e.g. “A”        100

Network (ODBC Database) Support [Advanced]        101

Overview        101

Configuring an ODBC Database        101

Important Note for 64-bit Windows Clients        102

“Cached” ODBC (ODBC, Sped Up)        103

Entry Locking        103

Locking the Database        103

Optimisation Tips        103

Notes for PostgreSQL        104

Commandline Options [Advanced]        105

Automatically Logging On to the Document Passed on the Commandline        105

Watch Folders [Advanced]        106

Lua Scripting [Advanced]        107

Getting Started with TshwaneLua Scripting        107

Lua Script Attributes        107

Stand-alone Scripts        107

Stand-alone Entry Scripts        108

API Reference Documentation, Tips, Samples and Further Information        108

Other Uses of Lua Within TLex/tlTerm        108

“Smart Styles”        108

Lua Filters        108

Lua Sorting        109

"Click Scripts" And "Search Scripts"        109

User Management        110

Configuring User Logins        110

Deleting Users: “Delete” vs. “Purge”        110

Privileges System        110

Field-Specific Privileges        111

Monitoring and Tracking Progress        111

User Progress Statistics        111

 

 

 

 

 

 

 

 

General Notes to the User Guide

 

TLex (also known as TshwaneLex) (for “lexicography”) is a specialised software application for compiling dictionaries. tlTerm (previously called TshwaneTerm) (for “terminology”) is a termbase editing application, i.e. a specialised application for compiling and managing terminology lists. (For a brief explanation of the primary differences between TLex and tlTerm, and when to use which, see the 'Getting Started with tlTerm' chapter). tlTranslate is a 'Translation Memory' application, for computer-assisted translation. The name 'Tshwane' stems only from the traditional African name for Pretoria, the city where the software was originally developed - the software itself, however, is fully internationalised, and can be used for virtually any language in the world. All fields in TLex, tlTerm and tlTranslate will thus accept Unicode characters (i.e. characters from any language). If you have problems displaying characters from a particular language, this is usually just a configuration problem (e.g. choosing the correct font).

 

Terminology Used in this User Guide

 

Throughout this document, the terms “lemma”, “entry” and “article” are generally used interchangeably or near interchangeably. The terms “lemma sign” and “headword” are used nearly interchangeably. The phrase “translation equivalent” is always used to refer to a more or less equivalent phrase in the target language in a bilingual dictionary, while the term “definition” is always used to refer to a monolingual explanation in the same language as the headword. The terms “element” and “attribute” stem from the terminology of the XML industry standard, on which TLex, tlTerm and tlTranslate are based. The terms “subentry” and “combination” are also used interchangeably.

 

Frequently Asked Questions (FAQ)

 

For additional documentation, tips and tricks, answers to common queries, information on undocumented features, and other information for getting the most out of your software, you should also regularly check out the FAQ (“Frequently Asked Questions”) document, available online at: http://tshwanedje.com/faq.html. The FAQ also contains supplementary documentation (e.g. on new features) that has not yet made it into the User Guide.

 

ChangeLog

 

The most up-to-date information on the newest features and fixes in the software is always published in the official ChangeLog at: http://tshwanedje.com/tshwanelex/changelog.html

 

Additional Resources

 

Free tutorial videos are available online via: http://tshwanedje.com/videos/

 

 

Getting Started with TLex: QuickStart Guide

 

Creating a New Dictionary Project

 

To start a new dictionary project, open TLex and select the “File/New dictionary” menu option. A dialog will appear prompting for basic information about the dictionary project, such as the name of the dictionary, an optional description, copyright information and URL (Uniform Resource Locator, i.e. website address, if applicable for the dictionary project). Note that these properties may be modified at any later time by using the “Dictionary/Properties” menu option.

 

Under “Dictionary type”, you must select whether you are creating a monolingual or bilingual (i.e. consisting of two “languages/sides”) dictionary database. If you want to create a semi-bilingual dictionary, choose the “Bilingual” option. Below this, under “Primary language”, enter the name of the main (primary) language for the dictionary (for a bilingual, this will be the “left” half or section), and if creating a bilingual dictionary, the target language name under “Target language” (this will be the “right” half or section). (Note that the “Noun classes” option enables features that are relevant to the Bantu language family, while the “ga/sa/se (Northern Sotho)” option enables a feature relevant to the Northern Sotho language.) The “Quicklinks” field is not important to the database itself – this is only used to configure the alphabetic shortcut links that will appear at the top of the TLex Preview Area.

 

 
 
 

Note that all fields in this dialog, as everywhere else in TLex, will accept Unicode characters.

 

Once you are satisfied with the basic properties for your dictionary, click “OK”. The TLex editing environment will appear, allowing you to begin compiling your dictionary. Before you proceed, select “File/Save” from the menu (or press Ctrl+S), and enter a filename under which to save your dictionary project. Thereafter, this dictionary database can be opened again by selecting the “File/Open: TLex (TshwaneLex) file” menu option and selecting this file. Also note that all recent dictionaries you have worked on are listed under the “File/Open recent” menu option. These actions are also available on the “start page” (“Tasks / Open recent”) that appears in the centre of the window when you open TLex.

 

Overview of the TLex/tlTerm Interface

 

Once you have created a new dictionary, you will be presented with the main editing environment. The default layout of this will depend on whether you are working on a monolingual dictionary or a bilingual dictionary.

 

Monolingual Editing Environment / tlTerm

 
 
 

On the screenshot, the four main editing areas have been marked “1” to “4”. These are discussed below.

 

 

 

 

 

 

 

Bilingual Editing Environment

 

For a bilingual dictionary, the interface is split down the centre, and similar editing windows for each side of the dictionary are shown side by side.

 

 
 
 

The four main editing areas, as indicated by the numbering on the above screenshots, are the “Lemma List” [1], the “Tree View” [2], the “Attributes and Tools window” [3], and the “Preview Area” [4]. Each will now be discussed briefly.

 

Entry List [1] (‘Lemma List’ in TLex, and ‘Term List’ in tlTerm)

 

This is a scrollable list of all entries in the dictionary/termbase. To view or work on an entry, click on the word / term in this list.

 

QuickSearch Box

 

Just above the Entry List is a “quick-search” box. When you start typing a word into this box, TLex/tlTerm will automatically jump to the closest matching entry in the list.

 

NB: The shortcut key “Esc” (escape) will always immediately take you to the quick-search box from almost anywhere in TLex/tlTerm.

Tree View [2]

 

Each dictionary article has a hierarchical structure, e.g. a lemma contains senses which may further contain subsenses. The Tree View is used to view or modify this hierarchical structure of an article,  e.g. to add senses, subsenses, usage examples, collocations, cross-references, etc. Each node in the Tree View is called an element. Right-clicking on any element in the Tree View displays a menu with a list of editing options available for that element, such as adding child elements.

 

Attributes (F1, F2) and Tools (F3, F4, F5, F6) Window [3]

 

This window consists of five sub-windows, which can be accessed quickly using the shortcut keys “F1” to “F6”. The first two sub-windows are used to edit the so-called attributes of the currently selected element in the Tree View, i.e. the actual values that are associated with the element. Thus the Tree View, which shows elements, is basically used to modify the skeletal structure of an article (e.g. adding a usage example at a certain point), while attributes flesh out that structure with actual content (e.g. the text of the usage example itself plus its citation). The “Attributes (F1)” window contains text boxes for editing text attributes of the currently selected element, while the “Attributes (F2)” window allows one to modify attributes that are constrained to selection from a defined list of values, such as a part of speech list (with the exception of single-selection lists, which also appear under “Attributes (F1)”).

 

“Search (F3)” activates a search function which enables text searches to be made in the entire dictionary. “Format (F4)” allows certain settings to be modified that affect how the output will appear in the Preview Area and when exporting the dictionary data (for printing or electronic display). The filter function, “Filter (F5)”, can be used to define criteria to work on or export a subset of the dictionary. The “Corpus (F6)” sub-window offers an integrated corpus query tool.

 

Preview Area [4]

 

This window displays an approximate representation of how the currently selected entry will appear in print (a so-called WYSIWYG (“what you see is what you get”) view), as well as displaying the articles immediately following the currently selected article. The Preview Area updates immediately as changes are made in the Tree View or Attributes (F1 and F2) and Format (F4) sub-windows.

 

One very useful feature of the Preview Area is the displaying of related cross-references of the currently selected article – all article that are cross-referenced by the current article, as well as all those that have cross-references to the current article, are displayed in the Preview Area.

"

Printing: Note that you can print the contents of the Preview Area (e.g. currently selected article) by right-clicking in it and selecting “Print...” or “Print Preview...”.

 

Bilingual “Side-by-Side” View Mode

 

For a bilingual dictionary, all four main editing areas are shown for each language, side by side. Each of these sides (containing the four main areas) is known as a “language editing window”, and the currently active language editing window is highlighted with a red border. (When one uses keyboard shortcuts such as “Esc” for the quicksearch box or “Insert” to add a new entry, these commands are activated for this currently active language editing window.)

 

“Expanded View” Mode vs. Side-by-Side View Mode

 

When working on a bilingual dictionary, the currently active language editing window may be expanded to occupy the entire TLex work area (as is always the case with the monolingual editing interface) by selecting the “Window/Expanded view” (Ctrl+W) menu option. This is useful for increasing the size of the work area when working mostly on one side of the dictionary.

 

To return to Side-by-Side View mode again, simply select this menu option (or press Ctrl+W) again.

 

Adding New Entries to the Dictionary/Termbase

 

 
The simplest way to create a new entry is to click on the “New (Ins)” button in the top left corner of the language editing window, or the “+” sign in the toolbar (see image at right). You will then be prompted for the headword/term of the entry to be added. Enter the headword and click “OK” or press the “Enter” key. A new, empty entry will be added, automatically correctly sorted. (If the new lemma is a homonym, the homonym number will also automatically be added by TLex.) To add word senses to the lemma, right-click on the “Lemma” element in the Tree View and click on “Add: Sense”. To add a definition or a translation equivalent (TE) to the sense, right-click on the newly added “Sense” element in the Tree View and select “Add: Definition” or “Add: TE”, and then edit the definition or translation equivalent under “Attributes (F1)”. Alternatively, as a shortcut, one may left-click on the “Sense” element and then enter a definition or translation equivalent directly into the “°Definition (NEW)” or “°TE (NEW)” textboxes under “Attributes (F1)”.
 

You can also use the “Lemma/Insert new lemma” menu option to add new articles to the dictionary, or use the “Insert” shortcut key on the keyboard. Note that when working on bilingual dictionaries in Side-by-Side View mode, these shortcuts will apply to the currently active language editing window, i.e. the side of the dictionary highlighted with a red border.

 

Structuring Articles with the Tree View Control

 

Adding: Right-clicking on any element in the Tree View shows a list of all possible elements that may be added as a child of that element. (Underneath the separator, cascades of child elements are also available. For example, instead of first adding the child element “Sense” to a “Lemma”, followed by the addition of the child element “Example” to that “Sense”, one may select “Add: Sense::Example” to obtain the same result with a single instruction. These “multi-element cascades” are shown with double-colons “::”.)

 

Deleting: Elements can be deleted using the right-click “Delete” menu option, or by pressing “Delete” on the keyboard, to delete the currently selected element.

 

Moving: Right-click options to “Cut” (Ctrl+X) and “Paste” (Ctrl+V) elements are also available. A pair of scissors “[8<]” is shown in the Tree View during the process of cutting and pasting, and will remain visible in front of the last element pasted (to show what is currently on the clipboard).

 

The right-click “Cut” (Ctrl+X) and “Paste” (Ctrl+V) menu options can also be used to cut and paste elements between different articles.

 

Drag-and-Drop: It is also possible to move elements in the Tree View around by dragging them with the mouse cursor. This is disabled by default, but can be enabled as a user preference with the “View/Tree View drag-and-drop” menu option.

 

Copying: A right-click menu option “Copy” (Ctrl+C) allows an element subtree to be duplicated anywhere else in the document via “Paste” (Ctrl+V).

 

When a particular element is selected, it can be turned into a sub-element by choosing the right-click “Make sub-element” menu option. This will typically be used to change senses into subsenses.

 

A particular translation equivalent (“TE”) can be turned into the first translation equivalent of a new sense with the right-click “Make separate sense” menu option.

 

Changing the Order of Elements

 

Elements on the same level in the tree hierarchy can be moved up and down, using either the right-click “Move up” and “Move down” options, or their corresponding keyboard shortcuts “Ctrl+Up” and “Ctrl+Down” respectively.

 

Changing the Order of Homonyms

 

To change the order of homonyms, right-click on the top-level “Lemma” element and use the right-click commands “Move homonym up” (Ctrl+Up) or “Move homonym down” (Ctrl+Down). The entries will be re-ordered and the homonym numbers will automatically update.

 

Marking Entries as 'Incomplete'

 

Entries that require further attention may be marked as “incomplete”. The complete/incomplete status of each article can be toggled with the “Incomplete” checkbox under “Attributes (F1)”, or by pressing Ctrl+Shift+I. Incomplete entries are displayed with question marks next to them in the Preview Area.

 

Various import and export functions of TLex/tlTerm make use of the “incomplete” setting. For example, when exporting data in preparation to be printed, incomplete entries are by default (this is a configurable option) excluded from the output, to help prevent you from inadvertently publishing unfinished entries.

 

Note that the “Filter (F5)” tool can easily be used to find and show all entries marked as incomplete at any time.

 

Saving Your Work

 

Newly created or modified entries are displayed with a “*” (or “!”) next to them in the Preview Area. This means “unsaved changes”, and appears on all new entries which have changes that have not yet been saved to disk. To save your changes, select “File/Save” (Ctrl+S). It is a good idea to do this regularly.

Restoring the Last-saved Version of an Entry ('Undo')

 

If, when working on an entry, you change your mind about the changes, it is possible to “restore” that entry to the last saved version. To do so, choose the “Edit/Restore” menu option (Ctrl+Shift+Z). This command will only have effect when there are unsaved changes in your entry, i.e. when a “*” appears next to that entry, and when the entry has been saved to disk at least once before.

 

Adding a Batch of New Entries, Or ‘Import Wordlist/CSV’

 

It is possible to add many entries to the database at once from a wordlist (one word per line), or from a CSV (Comma Separated Values) file from spreadsheet software such as OpenOffice.org or Microsoft Excel. To do this, use the “File/Import/Wordlist or CSV (Comma Separated Values)” menu option. See the chapter “Importing Data into TLex” for more information.

 

Deleting Entries from the Dictionary/Termbase

 

To remove an entry from the dictionary/termbase, select that entry in the Entry List, and click the “Delete” button (near the top left of the editing window). You can also use the keyboard shortcut “Ctrl+Delete”.

 

Note that in TLex, if you have other entries that contain “smart cross-references” to the entry you are deleting, TLex will warn you about these before deleting the entry. TLex will also automatically remove these cross-references for you if you proceed to delete the entry.

 

Printing your Dictionary

 

When you wish to print your dictionary, the simplest is to export it to RTF (Rich Text Format) and open it in any word processor, such as OpenOffice.org, Corel WordPerfect or Microsoft Word. Apply any final formatting changes (e.g. adding columns) in the word processor before printing. To export to RTF format, select the “File/Export/RTF (Rich Text Format)” option from the menu. An “Export options” dialog will appear (do not worry about these options at this stage, their meaning will be explained in the course of this User Guide). Click “OK”. You will be prompted to enter a filename for the output RTF file. If you are working on a (semi-)bilingual dictionary, you will be prompted for a filename twice – once for each side of the dictionary.

 

Note that by default, articles that have been marked as “Incomplete” (i.e. those that are displayed with question marks) will not be exported. This can be overridden, if desired, in the “Export options” dialog box, with a further option to hide the incomplete marker “?”.

 

Making Regular Backups

 

Manual Backups

 

For all dictionary and terminology projects, it is crucial to make regular backups. TLex/tlTerm provides a feature that makes it easy to quickly create a backup of your current database. To create a backup copy of your database at any time while working on it, select the “File/Create a backup” menu option. This will save a full “snapshot” of your database into a backup folder. (Note that, by default, this will typically be saved on the same computer as the file you are working on. This will thus not protect you if that computer is damaged or stolen; it is crucial to also make “offsite” backups, discussed below.)

 

The folder in which backups are stored may be configured using the “settings” dialog, which may be opened using the “Tools/Options” menu option.

 

Automatic Backups

 

In addition to the manual “File/Create a backup” menu option, TLex/tlTerm also has an automatic backup system that automatically saves a backup copy of the currently open database into the backups folder at a configurable time interval. By default, this is set to one hour (“60” minutes). Whether or not to perform automatic backups, and the interval in minutes, can be configured under the “Tools/Options” menu (on the “settings” tab labelled “General”). Every interval the previous backup is overwritten with the latest backup, but one backup each per twenty-four hours is kept.

 

All users are also very strongly encouraged to periodically make offsite backups, discussed next.

 

Offsite Backups

 

The backups created manually using “File/Create a backup” as well as the “automatic backups” will by default be saved to the same computer on which you are working (although you may configure this to save to a “mapped network drive” on another computer on the LAN (Local Area Network)). However, to protect against disastrous eventualities such as hard disk failures, theft, lightning, earthquakes, fires, nuclear incidents and so on, it is crucial to also have a policy for creating regular offsite backups – that is, backups that are stored at least in a different building to the one in which the computer being used to compile the dictionary is. This could be as simple as regularly writing a copy of your database file to a CD or flash disk and taking it to someone's home, or e-mailing a copy of the database to a colleague. You may wish to consider further protecting offsite backups by storing them in a safe.

 

It is recommended that you make an offsite backup at least once every two weeks.

 

“Cloud” Backups

 

Many service providers (such as ‘DropBox’) now provide automatic file storage services onto their servers on the Internet, with easy-to-use software that automatically uploads files from selected folders on your computer. This can provide an additional convenient offsite backup system for you. However, do be careful – if the only copy of your document is in that folder for “cloud” synchronisation, you can still lose the data if a corrupted copy is uploaded, as most such services do not maintain full file histories. Thus, such services may lull you into a false sense of security with respect to your data – use with caution as an additional backup facility. Also, services like DropBox are not implemented with ‘true’ encryption-based data protection – for an alternative that is, consider ‘SpiderOak’.

 

NB: An additional “security caveat” also applies for projects in which confidentiality is critical. Not all such services are as secure as one might expect!

 

Getting Started with tlTerm: QuickStart Guide

 

Creating a New Termbase

 

To create a new termbase, open tlTerm, and select “File/New terminology list”, or click on “Create a new terminology list” in the main 'Tasks' window. The 'create termbase' dialog appears:

 

 
 
 

The “Add language” and “Remove language” buttons can be used to enter the list of languages that you would like to treat in your termbase. The field list on the right can be used to select which types of information you would like to be able to enter for each term in each language. The various other fields are optional.

 

Most of the basic editing functionality in tlTerm is similar to TLex; please proceed by working through the “Getting Started with TLex” section. Terms are added in the Tree View.

 

Primary Differences Between tlTerm and TLex

 

The main difference between tlTerm and TLex is that terminology is concept-oriented, while lexicography is lemma-sign ('word' / phrase) oriented.

 

In terminology, an entry in the database generally corresponds to an abstract concept, e.g. you might have a database entry for the ‘abstract concept’ of a “cat” in general, i.e. not associated with any particular language. The terms for that concept in each of the various treated language are then attached, as “equals” and on the same level, to that central concept. Multiple terms that are synonyms in the same language would be attached to that same entry/concept, as they are merely additional terms for the same concept.

 

 
 
 

In lexicography (and thus TLex), an entry in the database corresponds to an actual orthographic word in a particular language, e.g. the actual “English word cat”. Any translation equivalents in other languages may then be attached to that word – like a “hub and spoke” model. Synonyms of that word in the same language (e.g. English “feline”) would be treated as entirely separate entries, (unlike tlTerm, where they would belong on the same entry for the ‘cat concept’), perhaps with cross-references to associate the two (e.g. a reference “see cat” under the entry for “feline”).

 

 
 

tlTerm, unlike TLex, also contains an extra drop-down list in the main toolbar, from which you can select which language you want to view / index (sort) the main Entry List on the left by. Entries (concepts) that do not yet contain any terms in the chosen language for that entry/concept are displayed in the list as a “-”. NB: This makes it easy to find untreated entries for a particular language. (This is similar to the “Sort by” function under “Format (F4)”.)

 

Changing the Interface Language (Localisation)

 

The interface of TLex itself can be configured via “Tools/Options”, under “Language”.

 
 
 

Built-in Localisation Editor – Creating New Interface Languages

 

TLex/tlTerm include the tools to change and edit their own interface language. These can also be accessed via “Tools/Options” under “Language”. This tool is fairly straightforward, and can be used to create new interface languages from within the software itself, by clicking on the “New” button, then using “Save as” when the localisation editor appears. The localisation editor will display an interface showing the original English strings, and a box where you can enter the translated string. Each string is also rooted to a “key” value, which looks something like “MENU_FILE” - this gives a clue as to where it is used in the software, e.g. all “MENU_” strings appear in the application main menu.

 

The 'Apply' button can be used at any time while translating to apply the new translations immediately (for some of them, however, a restart of TLex or tlTerm is still required).

 

When you click “Save”, the translated strings are saved in a “.lang” type file under a folder that will be something like “c:\Program Files\TLexSuite\Data\Catalogs”. This file can be distributed to other machines by just copying it into that folder. (It is in fact a simple text file.)

 

There are a few “special” characters and strings relating to the localisation:

 

& Appears in front of the character that will typically become a shortcut key to access the command, e.g. “&File” to make “Alt+F” open the “File” menu (in Windows, these may be underlined).

\t Indicates a “tab” character. This must typically appear in menu items between the command name and the shortcut key, e.g. “&Save\tCtrl+S” for MENU_FILE_SAVE. You enter a tab character by pressing “Ctrl+Tab”.

 

\n Newline.

 

%s Indicates that the software will, at run-time, substitute this with a string value, e.g. “Enter new text for label "%s"”.

 

%d Indicates that the software will, at run-time, substitute this with a numerical value.

 

Note that the relative ordering of %s and %d markers within one string must remain the same.

 

Keeping Your Software Up To Date

 

TshwaneDJe continually releases new “maintenance updates” for the software. These updates contain important and useful improvements and bugfixes, and it is strongly recommended that you keep your software up to date. You can check if there is a newer release available for your version of the software by using the “Help/Check for updates” menu option. This will open your web browser to a site that tells you if a newer version is available, and if so, tells you where and how to download it.

 

Maintenance updates (not to be confused with actual version upgrades) are free. When you install a maintenance update, re-activation is not usually required.

 

“Wide View” Mode and “High View” Mode

 

During compilation, it may be desirable to change the work area of the Attributes and Tools sub-windows (F1 to F6).

 

Encyclopaedia entries, for example, are typically much longer than dictionary articles, and one may want more “horizontal” space for the various input boxes. With the “View/Wide Tools window layout” menu option (Ctrl+Alt+L), the Attributes and Tools sub-windows (F1 to F6) can be widened to cover most of the width of the TLex/tlTerm window. This is illustrated for the compilation of encyclopaedia entries in the screenshot below:

 

 

Figure 8: “Attributes (F1)” in wide view window layout (Ctrl+Alt+L) for
James Randis Encyclopedia [Data online at:
http://randi.org/encyclopedia]

 

In other cases one may wish to see more “vertical” space, so as to for instance work with more input boxes under “Attributes (F1)” at a single glance.

 

This is typically the case in multilingual terminography. With the “View/Toggle Tree View” menu option (Ctrl+Alt+T), the Tree View can (momentarily) be hidden. In the screenshot below, for example, the high view window layout has been enabled for the compilation of an eleven-lingual AIDS terminology list.

 

 

Figure 9: “Attributes (F1)” in high view window layout (Ctrl+Alt+T) for an
eleven-lingual AIDS terminology list [Data: © Department of Arts & Culture, South Africa]

 

Note that although the wide and high view window layouts were illustrated for the “Attributes (F1)” sub-window, these views are also available for all other sub-windows (F2 to F6).

 

F12 Overlay Window (Larger Attribute Editing Window)

 

In addition to the “wide” tools window layout, another option to gain more editing space for editing the content of text boxes is the F12 overlay window. While in an “Attributes (F1)” text box, pressing F12 will pop up a larger window for editing the given attribute. Once done, pressing F12 closes the window again. While the F12 window is open, you can select any “Attributes (F1)” window, and the F12 window will automatically switch to editing that attribute. This window also allows newline characters to be entered in a more intuitive way.

 

The F12 window also works in various text edit boxes elsewhere in the software. (This can be useful particularly when editing certain types of text values, such as a Lua script.)

Attributes (F1) and (F2)

 

Attributes (F1)

 

The majority of a dictionarys article contents are typed into the various boxes under “Attributes (F1)”. This is the primary purpose of the F1 sub-window; however, one also edits drop-down closed list attribute values here. Drop-down lists allow only one possible value to be selected at a time. In the screenshot below, TLex is used as an address book, and the value of the “Country” attribute is being selected from a drop-down list.